Erreur dans le kernel unix

 dans Actus, Failles, Linux, Sécurité, Serveur

Yop les geek’s linuxiens,

Très récemment ( le 23/10/2012 ), un utilisateur Linux ( sous le nom de Nix ) a mis le doigt sur un problème assez inconnu dans le système de fichiers EXT4, si vous ne savez pas ce qui est l’EXT4, c’est un système de fichiers sous Linux comme il est possible de voir le FAT32/NTFS sous Windows par exemple.

L’utilisateur s’est retrouvé avec des données corrompues ( même voir totalement supprimées ) après avoir effectué un upgrade du kernel de la version 3.6.1 vers la version 3.6.3.

L’origine n’est actuellement pas connue mais d’après Theodore Ts’o, ce problème surviendrait après un arrêt brutal du système ( coupure de courant, débranchement du câble, reset forcé … ) quand justement le système est en train de faire le démontage de son système de fichiers.

Bon, ce n’est pas une confirmation, nous attendrons la suite pour savoir ce qui est à l’origine de ce problème ainsi que les versions des kernel réellement impactés.
Cependant, je vous rassure, cette erreur est assez rare et je vous recommande de couper votre système proprement, enfin comme il devrait l’être hein !

Les serveurs ( Debian, RedHat, CentOS, … ) fonctionnent sur des kernel en version 2.6.32 ( dans mon cas ) et donc n’est pas forcement impactés. Je vous demande donc de faire attention 🙂

A bientôt !

Articles recommandés
Showing 2 comments
  • Dieu Henriste
    Répondre

    Pourquoi cette image ? Ca m’a fais penser à Fable …

    • Djerfy
      Répondre

      Effectivement l’image n’a rien à voir avec l’article 🙂

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.